ADTF_CALIBRATION_TOOLBOX  3.4.2 (ADTF 3.12.7)
System Requirements


Note
We can only support these development setups for all platforms in combination with using CMake.
Warning
Mixing adtfplugins build with different build types (e.g. RelWithDebInfo and Debug) will work propably as far as thir dependencies will fit. This can lead to trouble for example using a Debug adtfplugin consuming Qt (Debug) but try to load it within a Release "ADTF Launcher" consuming Qt (Release). This won't work and could not be supported !


Warning
From ADTF 3.6.0 / Calibration Toolbox 3.1.0 onwards the Windows platform has been changed from VS 2015 VC140 to VS 2017 VC141 due to Windows 10 and High-DPI Scaling Support (this also means to upgrade Qt which removes the Qt Web Engine for 2015 VC140). Anyway, loading older adtfplugins build with the former toolchain is not supported ! Please recompile your components using the new VS 2017 VC141 toolchain against at least ADTF 3.6.0 / Calibration Toolbox 3.1.0 SDK !

Windows Desktop 64 Bit

  • We recommend our used and tested platform Microsoft Windows 10 64 Bit
  • On any other Windows 64 Bit platform (e.g. Windows 7) make sure that it fulfills the following requirements
Runtime requirements
  • Visual C++ 2017 Redistributable
  • Visual Studio C++ 2017 (for debug libraries and executables)
Development requirements
  • Visual Studio C++ 2017 (Version 15.x at least 15.9.11+28307.586)
  • VC141 Toolchain
  • Windows Kit 10 (at least 10.0.17763.0 shipped with Visual Studio C++ 2017)

Linux Desktop 64 Bit

  • We recommend our used and tested platform Ubuntu 16.04 LTS 64 Bit
  • On any other distributions (e.g. Fedora, Debian) make sure that it fulfills the following requirements
Development requirements
  • gcc >= 5.4
  • libc >= 2.23
  • libstdc++ >= 6.0.21
  • build-essential libarchive-dev mesa-common-dev mesa-utils libglib2.0-0

Copyright © Audi Electronics Venture GmbH. All rights reserved. (Generated on Tue Sep 14 2021 by doxygen 1.8.14)