ADTF_DEVICE_TOOLBOX  3.9.0 (ADTF 3.14.3)
System Requirements
Note
We can only support these development setups for all platforms in combination with using CMake.
Warning
Mixing adtfplugins build with different build types (e.g. optimzed like RelWithDebInfo and non-optimized Debug) will work propably as far as thir dependencies and (3rd party) ABI will fit. This can lead to trouble for example using a Debug adtfplugin consuming Qt (Debug) but try to load it within a Release ADTF Launcher consuming Qt (RelWithDebInfo). This won't work and could not be supported !


Warning
From From ADTF 3.14.0 / Device Toolbox 3.9.0 onwards the Windows platform has been changed from VS 2017 VC141 to VS 2019 VC142 and the Linux platforms has been changed from gcc5 to gcc7 due to issues regarding C++ language support and trouble with Qt 5.12.x. Anyway, loading older adtfplugins build with the former toolchain may work but can neither be guaranteed nor supported for any conditions and combinations ! Please recompile your components using the new VS 2019 VC142 / gcc7 toolchain against at least ADTF 3.14.0 SDK if you facing runtime issues !

Windows Desktop (x86_64)

  • We recommend our used and tested platform Microsoft Windows 10 64 Bit
  • On any other Windows 64 Bit platform (e.g. Windows 7 or 11) make sure that it fulfills the following requirements
Runtime requirements
  • Visual C++ 2019 Redistributable
  • Visual C++ 2019 / Visual C++ 14.2 (for debug libraries and executables)
Development requirements
  • Visual C++ 2019 (at least CXX Compiler MSVC 19.29) / Visual C++ 14.2 (VC142 Toolchain at least 14.29)
  • MSBuild Version 16.x (at least 16.11)
  • MSBuild Tools only or full Visual Studio IDE installation which covers this requirements
  • Windows Kit 10 (at least 10.0.19041.0)
  • CMake >= 3.18.4

Linux Desktop (x86_64)

  • We recommend our used and tested platform Ubuntu 18.04 LTS 64 Bit
  • On any other distributions (e.g. Fedora, Debian) make sure that it fulfills the following requirements
Development requirements
  • gcc >= 7
  • libc >= 2.27
  • libstdc++ >= 6.0.25
  • CMake >= 3.18.4
  • build-essential libarchive-dev mesa-common-dev mesa-utils libglib2.0-0 libxcb-xinerama0 xterm