Project

General

Profile

Actions

Support Request #2274

closed

Qt Gui filter linker error

Added by hidden almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Customer:
AUDI
Department:
AST
Requester's Priority:
Normal
Support Level:
2nd Level
Resolution:
No Customer Feedback
Affected Products:
Platform:
Windows 7 64bit
Topic:
ADTF::Common
FAQ Links:

Description

Supportanfrage

During the updation of the Qt filter's CMake according to the new ADTF3.3.0 build framework, I am facing some linker errors. When the qt gui filter is compiled, the compiler is not able to find the object file(ex. Qt5Widgets-NOTFOUND object). This can be
seen when user selects project properties->Linker->Input->Additional dependencies. Here instead of the library path or the library itself, it shows Qt5Widgets-NOTFOUND and I have highlighted it in one of my attachments (my_filter_QT5WidgetLibError.PNG).

In order to cross verify, I have tried to build the qt demo filter delivered by the ADTF3.3.0, somehow the project builds but the “Qt5Widgets-NOTFOUND” is still found in the Additional dependencies. How could this be resolved in order to compile my filter without linker failure? I have tried changing the linking syntax (for ex: target_link_libraries(${TARGETNAME} PUBLIC adtf::ui Qt5::Widgets/Widgets/Qt5Widgets)) but none of them are working.

CMake version used : 3.10.1

Lösung

  • QT_DIR-variable point to your own QT-Installation
  • CMAKE_PREFIX_PATH also to QT
  • Build Type must be RelWithDebInfo or Debug

Files

my_filter_CMakeLists.txt (940 Bytes) my_filter_CMakeLists.txt My Qt Gui filter CMake hidden, 2018-04-17 09:41
adtf_demo_qt_media_descp_disp_Qt5WidgetLibError.PNG (47.3 KB) adtf_demo_qt_media_descp_disp_Qt5WidgetLibError.PNG Missing object file of the demo filter from the IDE hidden, 2018-04-17 09:41
my_filter_Qt5WidgetLibError.PNG (82.5 KB) my_filter_Qt5WidgetLibError.PNG My Qt Gui filter linker error snapshot from the IDE hidden, 2018-04-17 09:41
Actions #1

Updated by hidden almost 5 years ago

  • Project changed from Public Support to 11
  • Topic set to ADTF::Common
Actions #2

Updated by hidden almost 5 years ago

Hello Vinay,

thank you for your feedback.
  • Does your QT_DIR-variable point to your own QT-Installation (the delivered QT within the 3rdParty is just "for us". It is not for developing)?
Actions #3

Updated by hidden almost 5 years ago

Hello,

My Qt_DIR CMake variable points to my own local Qt installation directory.

Actions #4

Updated by hidden almost 5 years ago

  • Status changed from New to Customer Feedback Required

Did you set the CMAKE_PREFIX_PATH also to QT ?
Please have a look at setups we made in the build_examples.bat

Actions #5

Updated by hidden almost 5 years ago

  • Description updated (diff)
  • Status changed from Customer Feedback Required to To Be Closed
  • Resolution set to No Customer Feedback

No customer feedback, issue will be closed

Actions #6

Updated by hidden almost 5 years ago

  • Project changed from 11 to Public Support
  • Private changed from Yes to No
Actions #7

Updated by hidden almost 5 years ago

  • Status changed from To Be Closed to Closed
Actions

Also available in: Atom PDF